Jump to content

Resuming a merge

Recommended Posts

While trying to check in my files I had to do a merge. I performed the merge and saved the conflicted file. When I closed the merge tool, the merge window still showed the file as needing a merge. I made the mistake of closing the merge window at that point. I'm not sure what to do to get back into that merge window. I can't check-in anymore because it says I'm in the middle of the merge. I've tried double-clicking on the merge-link shown at the bottom of Pending Changes as well as right clicking, but that doesn't do anything.

Am I missing something obvious here?


Link to comment
Share on other sites

If I already have pending changes (for example due to a half-completed merge) nothing happens when I press "Process all merges" (as seen in attached screen-cast).

Is this normal?

And if so, how do I continue with the merge?

I tried to undo all changes to reset the merge operation. I then tried to merge again and pressed "Process all merges". This auto-merged some stuff and presented me with a manual merge dialog which I completed and saved.

After that I still had 15 items to merge with changes in source only, but when I pressed Process all merges nothing happened as shown in the video.

The merge contains xlink changes and I suspect it could be a bug related to that


Link to comment
Share on other sites

Ummm nop! that's not a right behavior. Tell me if you are able to reproduce consistently the case and I will ask you for some data to fix the case.

It is reproducible. I have not been able to merge the branch yet.

Link to comment
Share on other sites

Yes. It is even repeatable on a different machine using a different server.

I have not tried merging the other way, but I would rather not, since that would require a merge of +20.000 test files added to /main since the unmergable branch was created.

When I try committing the merge I get this error:


Item 37 is the source folder of the project:

C:\Projects\PS.Vision\PS.Vision_Test>cm ls --format="{itemid} {path}"

2 c:\Projects\PS.Vision\PS.Vision_Test

201 c:\Projects\PS.Vision\PS.Vision_Test\Configurations

2 c:\Projects\PS.Vision\PS.Vision_Test\Data Sets

36 c:\Projects\PS.Vision\PS.Vision_Test\ignore.conf

37 c:\Projects\PS.Vision\PS.Vision_Test\Source

Needless to say, this is not some random file I could live without.

Here is the bottom of the log:


2012-07-02 12:54:11,514 INFO Performance - Checkin - Do - FillFSInfo: 15 ms

2012-07-02 12:54:11,521 DEBUG WorkspaceDataStore - ReadMergesToCheckin 0 ms

2012-07-02 12:54:11,645 INFO Serialization - Compressed 1618 bytes in 630 bytes. Time: 62 ms.

2012-07-02 12:54:12,950 DEBUG ClientSink - | TryCheckIn | proc 1404 | 12 | 67565736

2012-07-02 12:54:12,953 ERROR CmProxy - Error invoking method [TryCheckIn] [plastic://ihp_pegasus:8084/ItemHandler] A merge is needed from changeset /main#17 to changeset /main#7 (the changeset you are currently loading) in order to checkin. The checkin operation cannot continue. It is necessary to solve the conflicts by merging your current workspace contents with the latest contents of the branch you are currently working on. Then, you can retry the checkin operation.

2012-07-02 12:54:13,029 DEBUG BuildChangesTreeForPath - Processing recursive children

2012-07-02 12:54:13,058 DEBUG WorkspaceDataStore - ReadMergesToCheckin 16 ms

2012-07-02 12:54:13,059 INFO Serialization - Compressed 3784 bytes in 1597 bytes. Time: 0 ms.

2012-07-02 12:54:13,199 DEBUG ClientSink - | CalculateMerge | proc 140 | 12 | 67636096

2012-07-02 12:54:13,200 ERROR CmProxy - Error invoking method [CalculateMerge] [plastic://ihp_pegasus:8084/ItemHandler] Item 37 could not be found in the tree. The new tree cannot be built.

2012-07-02 12:54:13,200 DEBUG Checkin - Error: Item 37 could not be found in the tree. The new tree cannot be built.

2012-07-02 12:54:13,290 INFO Performance - Checkin - TOTAL: 2121ms

2012-07-02 12:54:13,290 DEBUG Checkin - __ Checkin ends _____________________________

I would really like to merge this branch to /main so please help.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...