Jump to content

Client configuration not creating client.conf file


Recommended Posts

I am having trouble getting started with Plastic running under Ubuntu 14. When I try to create a repository:


cm makerepository myrepository


I get this error:


"Plastic SCM client is not correctly configured for current user: Client config file /home/mark/.plastic4/client.conf not found."


I wonder if something broke during installation. Here's my installation story: The first installation attempt was with the downloaded .run file. However after that install, trying to launch the client by clicking the icon in the UI threw a bunch of fatal errors in the terminal. A web search revealed these Plastic Ubuntu 14 install instructions:




So I ran those commands in a terminal. The install seemed fine. Next, I launched the client configuration from terminal prompt:


sudo plastic --configure


The configure program seems to run fine. Click through screens, enter my info, program closes. But trying this command:


cm makerepository myrepository


That command then throws that error. Directory exists, but no client.conf file. What did I miss?


Thanks in advance!

- Mark M

Link to comment
Share on other sites

Ok, in that case you can do any of this options:


1) Change the permissions of the /opt/plasticscm5/client/client.conf to 777

2) Move the /opt/plasticscm5/client/client.conf file into "/home/YourUser/.plastic4/".

Link to comment
Share on other sites

OK, no client.conf file in that directory. So, created one, changed it's permissions, and now the configure wizard runs! Now we're cooking with gas.




When I tried running the client GUI icon, it complains that it doesn't have access to ~/.plastic4/client.conf.


So, as you suggested, I copied the client.conf out of /opt/plasticscm5/client/ to ~/.plastic4/, and changed the permissions on that directory to read/write, and now the Client GUI runs fine.

Woot! Hopefully the new permissiveness of /.plastic4 isn't a problem.


Thanks very much for all your help!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...