Jump to content

Error merge


k119_55524
 Share

Recommended Posts

Explanation:

1. I used an older version of PlastikSCM. The lightning bolt ruined the computer. I installed the latest version on a new computer (the image of the about window is attached).
2. We have several projects with common, shared code, connected via xlink. There is a master branch and working branches that we sometimes merge into the main branch.
3. Previously, if we made changes in the xlink repositories (more than 1 programmer at the time of merging), when merging the plastic, it would display a warning window about the changes made by another team member with subsequent merge. Most likely, the plastic raised the xlink to the actual one, and used it for merging in automatic mode.
4. In my latest version, such a window does not come out and I have to manually raise xlink, then merge the changes to the original branch and then merge to the required branch.

Question: is it possible to return the window that I wrote about through some settings or are there other ways to solve this problem? Or do I not understand something?

In the attached screenshots: the version of the plastic, the text of the error and the project tree with the unsuccessful merge.
 
1057/5000
 
 
Screenshot_2.png.9ea79ea3cdda81a6514cf30562b8d72e.png
 
Screenshot_3.thumb.png.d0cf8471fc6ca101373bd23495fe92ff.png
 
 
Screenshot_1.thumb.png.b87d1c04ece9923407f6aeeab239995d.png
 
1057/5000
 
 
 
 

Screenshot_2.png

Screenshot_3.png

Link to comment
Share on other sites

Hi,

When trying to checkin changes inside the Xlink, are you getting an "Incoming changes" window that is empty?

We are going to create a task so when this scenario happens, the "incoming changes" view is not empty anymore but alerting the user that they will need to run a merge inside the Xlink to update it to the last (or just update the Xlink to point to the last). An empty panel is not any help.

The thing is the "Incoming Changes" is not supposed to run merges but at least it should provide better feedback about what's happening. 
 

You can disable the "Incoming changes" in your "C:\Users\xxx\AppData\plastic4\client.conf" with the following setting and you should be able to go back to the previous behavior:

<EnableIncomingChanges>no</EnableIncomingChanges>

Regards,

Carlos.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...