Jump to content

desctop app login problem

Danek Bůhvíkdo

Recommended Posts

When I want to connect to centralised repository, I am prompted to login. If I choose to login with Unity ID, I am redirected to webpage, where it logs in with no problem but my desktop app says "unknown user: [my mail]. Please check your current credentials. Remember that user names are case-sensitive." If I choose login with email then it says "Invalid credentials, username or password are not valid."

I am sure I am entering correct name and passw because on the main Plastic scm (plasticscm.com) I can login with no problem.

Link to comment
Share on other sites

  • 3 months later...

@calbzam is there a fix for this Unity ID log in issue?

I have the exact same problem when trying to add a web trigger to the cloud server for a discord bot. It prompts me to sign in (even if I have plastic scm client running and configured), I choose "0 - unityid" to sign in, go to the URL, and the sign in works fine but the terminal process quits with the identical error message: 

Unknown user: 'xxxxx'. Please check your current credentials. Remember that user names are case-sensitive!

I have tried re-installing and double checking all of the plastic client configurations. Should I submit a bug ticket?

Link to comment
Share on other sites

Hi @calbzam,

Yes, the user (me) is registered at www.plasticscm.com with the Unity ID. When signing in through www.plasticscm.com, I use the "Sign in with Unity ID" feature successfully. However I am not a paid user -- I am using the Free tier of the Cloud edition.

I would guess the issue has to do with Plastic's command line interacts with the online login, as when it prompts me to log in with an oauth session, the website (which I paste the URL to) says I've signed in but the command line process quits out with the aforementioned error.

I am free to find a meeting time if you would like. I was away this week, hence the late reply, but I am back now and can assist in debugging!



Link to comment
Share on other sites


So we removed the user and re-invited them, and confirmed that login via "macplastic --configure" works perfectly.


However, the command line login when trying to add a webhook still fails. All of the normal Plastic functions (like the tool itself) have worked fine for this user, its very specifically when running a command in OSX terminal trying to add a web hook. This is the following command:

cm tr mk after-checkin NotifyTeam "webtrigger https://discord.com/api/webhooks/852273058877800469/XXXXXXX" --server=organization@cloud

And upon entering this command the user is prompted to login, and the aforementioned sequence and error happens.

Thank you for your continued help and I hope we can get to the bottom of this!


Link to comment
Share on other sites

Hi Carlos,

The user was following the tutorial at the following page:


After some testing and tweaking earlier this week, we discovered that this tutorial appears to be a bit outdated? It is from earlier this year, but trying to make a trigger on "after-ci" no longer works (returning a "specified trigger does not exist"). Just a heads-up in case other people are confused by this as well.

That said, we got it to work! It turns out the user had a typo in the cloud name for the --server parameter. That said, it always failed with the message:

Unknown user: 'xxx@icloud.com'. Please check your current credentials. Remember that user names are case-sensitive!

Which confused the user into thinking their email creds were wrong, when it was just that there was a small typo in the @cloud server name. Probably another good thing to note for others that may run into this in the future.

Thanks for your help!



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...