Jump to content

Missing UI When Right Click in Hierarchy Window - Have half fix


Recommended Posts


So in the Unity Editor, when I right click in the Hierarchy window, the UI menu item is not present. I tried lots of different things but eventually found that removing the project from the workspace folder and putting it somewhere like the desktop would bring back the UI menu item. I tried a couple more things and eventually found that removing the .plastic folder from the workspace folder brings back the UI menu item, but naturally, this breaks plastic. What's going in the .plastic folder that would break this menu item? How can I fix this? 


Thanks in advance...

Link to comment
Share on other sites

Hi @Hydrasin, I'm sorry that Plastic SCM is missing in the context menu of the Project Browser for you. That's very odd that it seems to only come back when the .plastic folder is removed from your project. Could you tell me the following so that we can try to reproduce it?

  • Unity Version
  • OS
  • Version Control package version
Link to comment
Share on other sites

Hi @ryancassell,

Thanks for responding. I agree that the behavior is extremely odd. Here is my configuration:

- Unity: 2020.3.17f1

- OS: Windows 10

- Plastic Version:


I just updated to this version of plastic because of this issue, but obviously it did not resolve the problem. 



I came across this thread in the Unity forum that discusses the issue but none of the solutions there have worked for me...


Link to comment
Share on other sites


I attempted to roll back to a older version of Unity (2019.4.0f1) but it didn't work and ended up breaking some things. There were a bunch of errors having to do with com.unity.collab-proxy@1.7.1 (located under ProjectFolder/Library/PackageCache/). In that folder I found a README which in one part said: 

This is the package to add Collaborate support to the Unity Editor. Unlike its predecessor CollabProxy,
this package has completely switched the UI to using UIElements.

I thought maybe Unity's Collaborate feature might be butting heads with Plastic. So I removed the "Version Control" package from the project via the Package Manager and voila, the UI option is now back where it should be if I right click in the Hierarchy window. 

I literally just made this discovery though and have to run out the door so I'm not sure what impact it will have elsewhere but hopefully it will offer some clues to you fantastic readers. More to come...

Link to comment
Share on other sites

Apologies for the late response. I was out for jury duty.

Thank you for the additional info. In the future, I would not recommend downgrading a Unity Editor to a previous major version, especially from 2020 to 2019. The Package Manager does not handle this edge case very well and can result in trying to load packages that are not supported on older versions of the Editor. Like you found out, the Version Control package implements the UI differently for 2019 vs 2020+ versions of the Editor, which creates a lot of Version Control-related compiler errors when you downgrade a 2020 version of the project to 2019.

Since you mentioned that you removed the Version Control package and was suddenly able to see the Plastic SCM context menu again, by any chance are you using the Plastic SCM for Unity Plugin from the Asset Store? (You can confirm this by checking if your project has a Plugins/PlasticSCM folder.) I ask because the context menu should only be visible if you either have the asset store plugin (which has been deprecated because it currently conflicts with the Version Control package) or the Version Control package of at least 1.7.x.

If the above is the case, then you should be able to return to Unity 2020.3, delete the PlasticSCM folder in the Plugins folder, then install the latest recommended Version Control package from the Package Manager to resume working as expected (with context menu intact).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...