Jump to content

CheckIn may not be possible if the workspace or repository is repeat recreated.


Recommended Posts

I have a question about Plastic SCM. 

I was learning how to use PlasticSCM while repeatedly deleting and creating repositories and workspaces with the same name. 
I was working on a distributed server and recreating both local and cloud repositories every time. 
During the work, I sometimes got an error like the attached image several times and could not check in. 
When I got this error, someone pushed the file from another workspace and I couldn't CheckIn until I pulled it. 
What is the cause of this? 


Link to comment
Share on other sites


Can you reproduce this issue?

Mt guess is the error is happening due to some manipulation performed with the repo/workspaces. It seems the workspaces has some changes in "test.txt" and when checkin in the file, it seems it doesn't exist anymore in the server. Maybe, because you deleted the repo and recreated a new repo with the same name.

If you do it, you will need to run an update in the workspace so the workspace metadata can be refreshed for the new repositry. Otherwise, it will try to commit the changes to a repo that doesn't exist anymore.



Link to comment
Share on other sites

Thank you for your reply. 

I created multiple local repositories and multiple workspaces, worked for 8 hours, and reproduced error about 8 times. 
When I got the error, I was able to correctly CheckIn to test.txt in the same local repository from another workspace. 
So is this a workspace side issue? 

Also, when I deleted the repository and recreated the repository with the same name, I was recreating the old workspace at the same time. 
It's not that only the workspace side is old. 

I pressed the update button in the attached image, but the error did not go away. 


Link to comment
Share on other sites

I wanted to use PlasticSCM at work, so I was doing various operations to learn how to use it. 
I didn't know the cause of the error that occurred at that time, so I was investigating.
I wanted to avoid the trouble of recreating the workspace during work. 
I feel that the above error sometimes occurs when recreating the repository and recreating the workspace quickly.

Link to comment
Share on other sites

When I select "Retry update" or "Update forced", an error like the attached image appears. 
What I'm worried about is whether this error occurs during development. 
I'm not sure what caused the error, but if I didn't create the repository or workspace many times, wouldn't the error occur? 



Link to comment
Share on other sites

For sure, this error is related to the workspace metadata. I'm pretty sure if it's realted to re-creating the workspaces and repositories. I haven't seen it in the past.

Not sure if you have reproducible steps so we can try it.



Link to comment
Share on other sites

Write the error reproduction procedure. 
I was working with a distributed repository. 


1:Create an "SCM" repository in the cloud. 

2:Create "SCM" and "SCM2" repositories local. 

3:Create an "SCM" workspace and a "SCM2" workspace. 
  Each is associated with a locally created repository of the same name. 
4:Create two sync view for synchronizing the local "SCM""SCM2" repository with the "SCM" repository on the cloud. 

5:Add the following files and folders to your  "SCM" workspace and check in and push. 
  "SCM2" will pull and update. 

6:Update the "./test.txt" from "SCM" and "SCM2" and repeat commit, push and pull. 
  Occasionally conflicts occur on purpose. 
  Repeat this until you have 12 to 15 changesets. 
7:Delete the "SCM" repository on the cloud. 

8:Delete the local "SCM" "SCM2"repository. 

9:Delete the "SCM" and "SCM2" workspaces. 


If you repeat steps 1-9, you will get an error and you will not be able to check in.
An error occurred in the 3rd or 4th repetition. 
(There were times when I recreated the sync view and times when I didn't, but I got an error in both. )

Link to comment
Share on other sites

I reinstalled PlasticSCM and tried again. 
Just in case, when uninstalling, it is installed after manually deleting the following folders.

AppData \ Local \ plastic4
Program Files \ PlasticSCM5 

After repeating steps 1-9 for about 40 minutes, an error occurred. 
The 3-4 repetition I wrote in the previous reply were few.
I'm used to the operation, so I'm doing steps 1-9 fairly quickly. 
and I have generated a lot of conflicts. 

It's scary because it's an unexplained error, but it may happen less often during development. 
If the cause of the error is resolved in the future, I would like an announcement or reply. 

thank you.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...