Jump to content

No Server Options in Linux?


Recommended Posts

I recently setup Plastic SCM in Linux Lite (Ubuntu 14.02 LTS variant) using this tutorial:




Everything appears to have gone fine, however I wasn't given any options to set the server database type, user authentication mode, or default path for repositories (if using SQLite). And I didn't get a GUI for setting up the server, is this to be expected? And am I to assume this is using SQLite by default? Where are the repos stored by default?

Link to comment
Share on other sites

Hi there,


yes, that's how it works, the package installer configures a server by default, that is Sqlite + LocalUsers auth mode.


You can stop the service and run the "clconfigureserver" script (if you don't have GUI) or "configureserver" in order to choose the auth mode, port, etc.


For the database, if you have GUI support you can use the admintool, if not you can manually change the "db.conf" file to target another DB engine. Check this link fro "db.conf" examples: https://www.plasticscm.com/documentation/administration/plastic-scm-version-control-administrator-guide.shtml#Chapter8:Databasesetup


BTW, the sqlite repos are by default stored at /opt/plasticscm/server.

Link to comment
Share on other sites

It's inside the Plastic SCM server directory, /opt/plasticscm5/server.


I realize now that you might not have a script to run it so here it's one:


PLASTICCLIENTDIR=`dirname \`readlink -fn $0\``
exec "$PLASTICCLIENTDIR/mono_setup" cm mono "$PLASTICCLIENTDIR/admintool.exe" "$@"

Save it inside the server directory and run "./admintool"

Link to comment
Share on other sites

  • 3 weeks later...

I stopped the server using "sudo ./pasticsd stop", then ran "gksudo ./configureserver", and it seems something was awry (see attached screenshot). I wasn't able to configure the server, and there was a warning icon next to the disabled configure button. Any ideas? I wanted to change the repository folder.


Link to comment
Share on other sites



The button is disabled because the "migrate" feature is not totally supported in Linux, you can manually execute it bu running "mono admintool.exe"

But I'm afraid the admintool/Migrate won't allow you to change the repository folder, only the database backend. 


It's much more easier if you manually edit the "db.conf" file.


If you want to change the database path that can be done adding (or modifying it if you already have it) the following XML tag:


After changing the value you'll need to restart the Plastic SCM server service.


BTW, the warning icon is because sqlite shouldn't be used for a multiple-user server, only for local servers (single user).

Link to comment
Share on other sites

I'm good now, was just confused by the warning icon as it didn't explain (no hover over etc.) why it was there, and any reasoning behind the button being disabled, but you cleared that up for me now.


* Thanks for the tip on changing the repo folder, that was the last piece of the puzzle I needed.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...