Jump to content

Continue a pending merge (link)


Beennn
 Share

Recommended Posts

I'm having some trouble getting a merge to finish.

 

  1. I went to check-in my local changes, and received a pop-up asking me to merge. 
  2. I clicked merge, then processed the changes
  3. During this processing, I received a number of error windows
    1. cannot perform an exclusive lock on the same item (this also duplicated all of the files in the project with (name_conflict) amended to the file name
    2. cannot retrieve licence information from plastic scm server (this has since been resolved)
  4. I then tried shelving the changes as suggested here (https://forum.plasticscm.com/topic/20298-checkin-operation-cannot-be-started-because-there-is-a-merge-in-progress/) and got: the shelve operation is not currently available in the cloud server
  5. My pending changes window is now cluttered with a mix of my pending changes, and a mix of things part merged via the merge tool. 
    1. I'm unable to choose which files to undo
    2. I'm unable to check the files in
    3. The only thing i haven't tried doing (as far as i'm aware), is undoing the changes; i'm not sure if this will undo ALL of the changes, or just the changes from the merge

My question is:

How can I continue the merge process?

 

On the pending changes screen, i can see: 1 pending merge link(s) Pending merge links will be commited when you checkin your changes or reverted if you undo your changes

 

 

Any help would be greatly appreciated

 

Link to comment
Share on other sites

  • 2 years later...

I wanted to push my changes. I couldn't do it, because there were newer changesets. I wanted to update, but the merge was required. I wanted to merge, but the merge couldn't be completed due to what it seems are "info" level warnings. It's absurd. I will have to manually backup my changed files and revert both merge and my changes.

Please tell me I can do it "correctly", as such deadlock should not happen in any VCS.

image.thumb.png.f629ba3fc63dc057790e5f7def602662.png

 

Merge that cannot be completed (hitting apply does nothing):

image.thumb.png.aaf2aecc5004594ebcb9470d6c65c0e0.png

Best,

Chopin

 

Link to comment
Share on other sites

Thanks, next time I will definitely contact you with this e-mail, forum is too slow :D

For now I "fixed" it by manually backing up my files and reverting all changes. Sadly, I couldn't pull the remote branch first, as the merge was required and the merge couldn't be completed because of reasons (picture from my previous post).

Best,

Chopin

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...