Jump to content

Using Proxy server with Plastic cloud


darrensocks
 Share

Recommended Posts

Hi,

The documentation seems to suggest the proxy server can be used with Plastic cloud, but I can't seem to find any information of how to configure this.


Does the proxy server support the cloud?
Can the teamcity plugin be configured to use the proxy?

Thanks

Link to comment
Share on other sites

Firstly, it says to download the Proxy Server Installer from your downloads page. There is no Proxy Server Installer as far as I can see in your downloads, only the portable proxy server. When I download and extract that, it appears to just be a normal server?

After downloading the .NET Core Proxy server from www.plasticscm.com --> Downloads --> More installers --> Proxy server .NET Core bundle

1) Copy the following files from the "config_samples" folder to the binaries folder:

  • plasticcached.conf 
  • plasticcached.log.conf 
  • plasticcached.network.conf


2) In "plasticcached.conf " you set the output path for the output cache folder. 
    In "plasticcached.network.con" you set the port.

3. You can run the proxy in console mode via this command:

C:\Users\albaz\Downloads\PlasticSCM-10.0.16.5432-win-x64-proxy-server-netcore\server>plasticd.exe proxy
plasticcached daemon up. 10.0.16.5432 313 ms startup time. Data path: C:\tmp\cache


4. In order to install the proxy as a Windows service:

sc.exe create plasticscmservernetcoreproxy binPath= "C:/PathTo/plasticd.exe proxy"



The proxy server by default listens on the 8085 port: YOURSERVER:8085

Could you rename the following file, restart the GUI and check if this way you can enable the proxy?
C:\Program Files\PlasticSCM5\client\cloudedtion.token

?name=inline114617812.png

 

- At the end of the day, The TeamCity plugin just internally runs "cm" commands so you could configure the Plastic client intalled in the TeamCity machine to use the proxy server.


Regards,
Carlos.

  • Like 1
Link to comment
Share on other sites

Although the visual editor is now working (with the cache) It looks like TeamCity won't connect to the server.

When I try to "Test Connection" it never seems to return a result. I did at some point have this working (before I setup the proxy). I've copied "client.conf" to the client folder as suggested in another post - This I think got it working but that was before I started using the proxy setting. I've tried removing the proxy server setting but still doesn't seem to work.

Link to comment
Share on other sites

Hi,

- I'ts very important that you copy the "client.conf" to the "client" binaries folder. I guess the TeamCity server is running with a different user taht your Plastic user (eg: SYSTEM user) and after copying the "client.conf" to the binaries folder, all the machine users will be using the same client configuration.

- If you have any "cm.exe" process running in the TeamCity machine, please kill them so it's restarted with the new client configuration.

- Let's try to make it work first without the proxy server. The proxy server is just a field inside the "client.conf":

<CacheServer></CacheServer>

Regards,

Carlos.

Link to comment
Share on other sites

Hey both, agent and TeamCity server are running on the same machine (not sure if that makes any difference). Both look they are using SYSTEM user.

I've made a build step which was just 'cm lrep'

The output was the following (*** the @cloud name but the team name is correct)

Quote

Select the system you want to use to sign in to the organization: **********@cloud
14:12:06   0 - unityid
14:12:06   1 - email
14:12:07   Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your system [0-1] Select your sy....................

So I'm guessing it's trying to auth me again?


A build step with the command 'cm whoami' outputs my user email correctly so it does seem to picking up some details correctly.

If I just do 'cm lrep' using a command prompt (same machine) it returns correctly.

 

Link to comment
Share on other sites

Copying the *.conf files to the "client" binaries got me a bit further and allowed the test connection to come back success, although it didn't seem to be fully connecting.

After some more poking around (I wish I could say what the solution was), everything now seems to be working correctly with the proxy server and TeamCity.

 

Thanks for your help!

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...