Jump to content

Merge bug leads to unopenable and irevertable scene


Recommended Posts

Hi

Up until 2 days ago merging worked fine-ish, both with scenes (.unity) and assets. Yesterday, scene merging was unavailable due to "merge tools not being correctly configured in client.conf". After some troubleshooting,  it appeared the path to UnityYAMLMerge.exe had changed (who knows why, I have not changed anything nor noticed any update). After setting it correctly, I was able to merge the scene but manually (and this had been automatic until then, moreover the changes were not conflictual, and a really small part of the whole file). Since manual merging of scenes is impossible to make sense of, I just accepted changes from both source and destination. It was a bad idea since it duplicated every object in the scene (I guess) and the scene was just empty in the editor, which didn't display anything else than "duplicate ID" error logs.

So I reverted the scene back to a point where it was functional in the plastic GUI, but despite this being successful the duplications errors and the empty scene stayed. I thought that maybe the revert merged the ancient scene with the new buggy one, changing every asset but not deleting its twin. So I deleted the scene and recreated one with the same name, only for plastic to tell me that the scene ID was duplicated and it will not let me revert. What do I do now? Do I wait for a coworker to push his own scene (and maybe face the same problem)? Is there a way to reload the scene in its state before the buggy changes (besides the following)?

 

I tried to download the scene and put an old version back in the project. Yet I get "Error loading the file 'Assets/Scenes/buggy_scene.unity'. File has multiple objects with same identifiers. Probably caused by a merge." and a host of "Duplicate identifier 13358067. File: "Assets/Scenes/buggy_scene.unity"." whith the id changing. The scene still appears empty in the editor.

Any help would be greatly appreciated.

Link to comment
Share on other sites

  • 2 weeks later...

Hi @SweatyDev, glad to hear that you were able to restore your scene from a previous version.

This sounds like it may have been more a problem with UnityYAMLMerge itself than with Plastic SCM specifically. Merging scenes has been an age old problem for Unity and it is advised to work on separate scenes if possible, this could be done by:

  • Working on different scenes completely
  • Working on different prefabs within the same scene
  • Manually allowing only one user to work on a scene at one time (Or semi-automatically with an exclusive checkout workflow)

Hope this helps.

Link to comment
Share on other sites

  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...