Jump to content

GitSync not working (with this specific repo) with BitBucket


Recommended Posts

Hi cidico, I will check the capitalization of files, may be this is the problen. I'm using Visual FoxPro, and it have the bad habit of changing the capitalization of files, so this could make trouble.

I just don't know if there is a way to change the capitalization of all files to normalze them (may be accesing the database directly?)



Link to comment
Share on other sites



Are you trying to sync your local Plastic repository with a clean GitHub one, right? Could you  send us the repository or the fast-export package?  

cm fast-export repo@server:8084 --no-data 

I will try to reproduce the issue and debug the problem.




Link to comment
Share on other sites

I've tried, but:


1st try with --no-data switch:

C:\Users\windows>cm fast-export foxbin2prg@win7u:8087 --no-data
fast-export: Unexpected option --no-data
Exports Plastic SCM repository data to a fast-export format.



2nd try without --no-data switch:

C:\Users\windows>cm fast-export foxbin2prg@win7u:8087
Getting branch list...
Getting changeset list...
Building changeset list...
1 changesets retrieved
1 changesets will be exported
0 labels will be exported
0 merges found
0 csets are out of order
Skipping changeset 0@/main.

 Directorio de C:\Users\windows

12/12/2013  18:01                 0 fast-export.dat


Export file es empty! :-(

Link to comment
Share on other sites

Ups sorry, the option is "--nodata" (without the middle "-")

C:\Users\windows>cm fast-export foxbin2prg@win7u:8087 --nodata

But checking the second try, it seems that you are exporting an empty repository, only 1 changeset is retrieved (the default one that is created when the repository is created). That´s the reason why the export file is empty. Could you review if "foxbin2prg" contains more changesets??


In case the repository is not empty I would like to get connected and review why it´s failing.




Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...

Hi Carlos!


I tried the version and you guys have made an nice progress!

I was finally able to do the "initial sync" with a git repository @ BitBucket!


The problem now is that after a few checkins, the git repository seems to be getting "corrupted".

Plastic appears to sync nicely and no error messages are displayed now, BUT, in the fact, no sync was made at all. After that, I can't access my git repo.


I know I'm been very annoying about this feature, and, for what I can see, only we (me and @fdbozzo) are having this issue.

Last night I tried to sync some dumb repos, and everything was working fine UNTIL I branched and performed a merge.

It was already late and I was not able to perform more specific tests to try to isolate the problem.


As I said, no error messages are displayed by Plastic but no sync was made at all and Plastic was not "aware" of it.


Thanks for your time and patience! :)

Link to comment
Share on other sites

Hi @cidico,


We are fixing this week two GitSync bugs. One was related to using Spanish accents (eg:  "cámara" ) or other symbols in labels and branches, the other one is related to using blanks in tag names. We figured out that @fdbozzo issues was related to this circumstance.


Could you confirm if your issues relate to the same scenarios?


Best regards,


Link to comment
Share on other sites

Hi Carlos!


Yes, I do confirm the usage of such chars!

As my natural language is Brazilian Portuguese I tend to use a lot of "á, ó, é, ç, ã, õ" and several others chars!

I my first repo (the one that started this thread), I don't remember if I have spaces at tags, but, I have a lot of spaces on labels and comments.

I don't remember right now, but I once told you that the sync was being made but there was a problem in comments and branch's names.

Their names were being cropped. 


If you want, after doing the fix, I volunteer myself to run a "special build" or something like that, with the fix to help you confirm the fix! :)



Link to comment
Share on other sites

  • 2 weeks later...

Hi Carlos!


As always, I try to keep the latest version of Plastic SCM running on all my machines...

In the release notes of I found these two bug corrections:



GitSync: Push branches or tags with non ASCII characters was failing.

GitSync: Plastic labels with spaces and other illegal git characters
were not being pushed to Git. Fixed. Now they are pushed, the name
exported to git will be the same in plastic but replacing these
illegal characters with a dash ('-').
E.g.: "Label 1" will be pushed as "Label-1".



Are these fixes THE fix for the issue described in this thread? :)


If yes, I'll try this build tomorrow! :)


Thanks in advance!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...