Jump to content

Fails to start server on Debian x86 installation


Recommended Posts



I'm attempting to install the server on a ReadyNAS linux box running: 


Linux version (jmaggard@calzone) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)) #1 SMP Thu Jul 26 05:00:36 PDT 2012


It all seems to install and configure ok but when I start the server I get the following error:


READYNAS:/opt/plasticscm5# ./server/plasticsd start

Starting PlasticSCM server: No directory, logging in with HOME=/

Unable to start PlasticSCM server. Please, take a look at the plasticFAILEDr.log file, placed in the plastic server location, for more details.


I guess I'm missing something but I can't seem to find the Linux docs on the website so am pretty much flying blind here. Any help would be greatly appreciated.







Link to comment
Share on other sites



We have recently released Plastic Linux packages. If you are using a compatible OS we recommend to use the packages: https://www.plasticscm.com/plastic-for-linux/index.html


If you are using the installer, after the installation process, the server should be up and running (If you are trying to do it manually I guess is because it wasn´t working). 


At:  "/opt/plasticscm5/server"  you will see a log text file: "loader.log.txt"/plastic.log.txt    .  Could you attach this information to check the error?




Link to comment
Share on other sites

Hi Carlos,


Thanks for the link to the linux pages!


I installed the server using PlasticSCM- from the downloads page. It installs correctly and only fails at the end when it can't start the server.

It also fails to write the log file so I can't see the error. I reinstalled as root and chown'ed the whole lot to make sure it wasn't a permission error but it still fails to write the log or start the server.



Link to comment
Share on other sites

Hi Richie,


the packages must be installed with root.


Can you please open a root terminal and run:


mono plasticd.exe --console


check then the log file and if you get any of them written in the console.


The mono installation executable should be in "/opt/plasticscm5/mono/bin/mono"

Link to comment
Share on other sites

Hi Manu,


So I when I run mono I get an unknown assembly: plasticd.exe error. 


I tried following  the install steps  on the linux pages but it fails  to install the packages via apt-get. I'm starting to think that it's not going to work with my version of linux?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...