Jump to content

JIRA - interactive link to changeset


Recommended Posts



I am trying to set-up JIRA and PlasticSCM together,


I succeed with whole set-up. Entries from JIRA are seen by PlasticSCM and also CustomeField gets updated.


The only what is missing for me is that entry: plastic://... is not displayed as "clickable" link.


I used this blog post as reference:



I have also find some blog post about WebUI. Is it still available in 5.4 version? Where can it be found?

Link to comment
Share on other sites



the installer is in charge of doing it but double check it just in case....


You need to install the "plastic.reg" file attached: plastic.zip

Edit the plastic.reg file and change the paths on sections:
    [HKEY_CLASSES_ROOT\plastic\DefaultIcon] and [HKEY_CLASSES_ROOT\plastic\shell\open\command]
    in order to point to the right "plastic.exe" executable file.
After installing the "plastic.reg" file the plastic:// links should open the Plastic SCM GUI views.



Link to comment
Share on other sites



Thanks. I also supose that it can be JIRA problem.


I am trying to overcome it by installing WebUI but it looks that I'm stack.


Application was added in IIS. It works in DefaultAppPool.

When I open it in browser "WebUI Login Screen" appears but I am not able to login (even providing right credentials).

In bin folder there is webui.log.txt with following entry:

2015-01-14 15:21:19,396 ERROR Authentication: Unable to validate user 'xxx': Access to the path 'plastic4' is denied.

I have changed permissions for bin folder and then 'plastic4' folder was created there. But error still appears (I also provided full access for IIS_USERS and later of even for Everybody). Any hint?

Link to comment
Share on other sites

Nearly worked :(

I created dedicated ApplicationPool for WebUI. I configured this pool identity to use same account as PlasticSCM server and attached WebUI application to this pool.
Error about access to plastic4 is not more shown but other appeared.
It looks that WebUI tries to connect to PlasticSCM Database (SQL Server Express) as "NT Authority\SYSTEM"
But such login is not defined in Database and I'd prefer to avoid adding it (as it would require adding users in every repositories already created).
I changed "anonymous" identity. I dig whole IIS configuration and cannot find why it still tries to use this account.

I even tried to change web.config file and changed connection string to not use integrated authentication but it did not change anything.
Any hint?
Thank you in advance.


Alert cancelled. It looks that I have changed PlasticSCM Server account and problem was there not in WebUI.

Right now all is working fine. Sorry for confusion.

Link to comment
Share on other sites

Great! :)


Returning to the original issue regading Jira, our Korean partner solved the issue by using the following "jira-config.properties" file (http://codicesoftware.blogspot.com/2014/03/jira-6-integration-improvement.html) with HTML tags:

plastic.formatdata=\r\n{{html}}<html><head></head><body><p><p><br>Date: {0}<br>Changeset {1}@{2}@{3} by {4}<br>Diff: <a href={5}>{5}</a><br>Branch: {6}<br>Comments: {7}</body></html>{{html}}

Tell me if it helps!

Link to comment
Share on other sites

  • 2 years later...

In case anyone else is trying to link to JIRA, here's what I had to do:

Make the text field as described in the PlasticSCM documentation.

Change the text field renderer, as described here: https://community.atlassian.com/t5/Jira-Core-questions/How-to-make-text-field-multi-line-custom-field-support-text/qaq-p/182022

Change the text field to support HTML: https://confluence.atlassian.com/jirakb/how-to-enable-html-in-jira-text-fields-771895067.html

Use the HTML workaround described here: https://jira.atlassian.com/browse/JRASERVER-26419

Set up your plastic.formatdata as described here: http://blog.plasticscm.com/2014/03/jira-6-integration-improvement.html

Get a formatdata string that looks good to you, I used this:

plastic.formatdata={{html}}<a href={5}>cs:{1}</a>{{html}} by [~{4}] in branch {6} on {0}\r\n{{panel}}{7}{{panel}} {{panel:borderStyle=dashed}}{8}{{panel}}

NOTE: In the formatdata you need to escape '{' characters with a second { unless you're using them for the numbered tokens.

Link to comment
Share on other sites

Hi @Misieq,

yes! I'm wondering why it's not documented but as I see in the code the "{9} field will retrieve it.

It's there since "" and here you have the release notes:

Changeset Guid is now available in the checkin log of JIRA extension. It is saved in the Plastic SCM custom field. The GUID is located after the changeset specification (which uses the changeset id instead). An example of the logged information is the following:

Date: 9/10/2015 12:25:25 PM
Changeset 24@default@localhost:8084 by dhernandez
Changeset guid: 5372daf7-f740-4d05-b9d2-a30823907bb2
Branch: /main/scm002
Comments: Rename some items

  Changeset 24@default
  M /client2008.csproj -> /client2010.csproj 
  M /server2008.csproj.-> /server2010.csproj


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...