Jump to content

MacPlastic Beta - Can't get LDAP to work

Recommended Posts

We are using the latest version of MacPlastic, and I'm having users that cannot get their LDAP credentials to work. We want to use the beta, because they have separate issues with the X11 client (it won't start).


Using the UI, it displays the error "The requested feature is not implemented" when we try to login.  I think it might trying to use Active Directory for some reason.


However, it works on my Mac, but I think only because I had the older X11 version of plastic installed and then upgraded.


I tried editing the file ~/.plastic4/client.conf, and adding the following lines:


This gets me past the startup screen, but I still can't get the correct credentials entered in preferences... I always get that same error message.

Link to comment
Share on other sites

Sorry, I guess didn't have it set to get an email from a reply. Just saw this.


It seems to happen on any *new* installation that didn't have the old Quartz/X11 version of plastic beforehand.  I'll see if I can find a machine and get you the logs.


To fix it, we had to configure the user's login on Windows and copy their client.conf file to the Mac for it to work.

Link to comment
Share on other sites

In ~/.plastic4, you can place client.conf there. This is where the app's config directory is on Mac.


I don't have a machine experiencing the issue anymore, because I applied this workaround to get my teammates going.


To reproduce it, I think you just need a fresh install of OS X and try to setup LDAP authentication. I'll post here if we setup a new mac and experience the issue.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...